So-net無料ブログ作成
検索選択

クラスファイルのバージョン 49.0 は不正です。48.0 であるべきです。

結構なつかしいエラーがでました。
経験上このエラーはJSPのコンパイルに用いるtools.jarが古いために発生することが多くて
今日もそのせいで発生してました。対処方法をメモ。

1.tomcatが使用するtools.jarを更新する。
使うjarファイルの場所:(使用するJDK)\lib\tools.jar

tomcatが使用するtools.jarは、tomcat\common\libにおいたり、
eclipseで指定したりするので、ファイルを上書きしたり、設定を見直したりしてください。

2.workフォルダjavaファイルを削除する。
昔のtools.jarで生成したjavaファイルが残っているとエラーがなおらないはずなので
workフォルダにできたファイルを削除してしまいます。

コメント(0) 

コメント 0

コメントを書く

お名前:
URL:
コメント:
画像認証:
下の画像に表示されている文字を入力してください。

この広告は前回の更新から一定期間経過したブログに表示されています。更新すると自動で解除されます。

×

この広告は1年以上新しい記事の更新がないブログに表示されております。